Again, an error
September 05, 2007 07:03AM

PHP 5.2.3, PEAR - last version, /usr/local/lib/php in path

When upgrading to HTMLPurifier version 2.1.2 (most recent), things stopped working :)

PHP Fatal error: Class 'HTMLPurifier_AttrDef_URI_Email' not found in /usr/local/lib/php/HTMLPurifier/AttrDef/URI/Email/SimpleCheck.php on line 9

That is achieved just by requiring HTMLPurifier.php.

Re: Again, an error
September 05, 2007 07:13AM

Mrmm... you can delete the contents of that file for now. It doesn't do anything. I wonder why PEAR is barfing though...

Re: Again, an error
September 05, 2007 07:53AM

And what will happen when I will upgrade though "pear upgrade channel://htmlpurifire.org/htmlpurifier" with next release?

Re: Again, an error
September 05, 2007 07:15PM

Because PEAR (as far as I know) doesn't do incremental updates, a newer version will cleanly write over the edited files. If it turns out that class will be used, it will have been changed. If the class is not to be used, well, no problems.

Re: Again, an error
September 05, 2007 07:21PM

Figured out the error (it's one we've seen before): poorly ordered include lists, basically including sub-classes before the parent class. I don't know why this doesn't result in errors on my system.

James Dee
Re: Again, an error
September 18, 2007 11:32PM

I'm trying to run HTML Purifier 2.1.2 php4 and I am getting this error. Is there a fix ?

Re: Again, an error
September 18, 2007 11:33PM

Yes, delete the contents of the file that is attempting to do the offensive include.

Sorry, you do not have permission to post/reply in this forum.