Welcome! » Log In » Create A New Profile

Ruby elements 'not supported'

Posted by dlstr 
Ruby elements 'not supported'
July 01, 2017 02:12AM

Hi,

I'm having issues with the library claiming that ruby tags (ruby, rb, rp, rt, rtc) are not supported by default. This appears to not be the case, however, as definitions appear in `/HTMLModule/Ruby.php`

There's the potentiality that I've missed one or more changes along the pipeline that have either temporarily removed, permanently removed, or feature locked support for the ruby family of tags, but I've found no immediate evidence of such a change.

The only customization features I'm using are implementations of three missing tags (mark, time, wbr), escaping invalid tags, and removing the `a` tag by whitelisting everything else (in addition to the mark, time, and wbr tags)

What could be going awry? Am I missing some hidden feature, or perhaps implementing my configuration incorrectly? Or am I misunderstanding the contents of `/HTMLModule/Ruby.php`?

The error:

Warning: Element '{ruby element*}' is not supported

*{rb, rp, rt, rtc, ruby}

The whitelist:

abbr,b,bdo,blockquote,br,caption,cite,code,dd,del,div,dl,dt,em,h1,h2,h3,h4,h5,h6,

hr,i,ins,kbd,li,mark,ol,p,pre,q,rb,rp,rt,rtc,ruby,s,samp,small,span,strong,sub,sup,

u,ul,var,wbr

Edited 3 time(s). Last edit at 07/01/2017 02:18AM by dlstr.

Author:
Your Email:

Subject:

HTML input is enabled. Make sure you escape all HTML and angled brackets with < and >.

Auto-paragraphing is enabled. Double newlines will be converted to paragraphs; for single newlines, use the pre tag.

Allowed tags: a, abbr, acronym, b, blockquote, caption, cite, code, dd, del, dfn, div, dl, dt, em, i, ins, kbd, li, ol, p, pre, s, strike, strong, sub, sup, table, tbody, td, tfoot, th, thead, tr, tt, u, ul, var.

For inputting literal code such as HTML and PHP for display, use CDATA tags to auto-escape your angled brackets, and pre to preserve newlines:

<pre><![CDATA[
Place code here
]]></pre>

Power users, you can hide this notice with:

.htmlpurifier-help {display:none;}

Message: