Welcome! » Log In » Create A New Profile

Allowing strikethrough tags 's' not working

Posted by TheBigK 
Allowing strikethrough tags 's' not working
May 09, 2018 01:50AM

Dear fellow members,

I'm trying to get the simple 'strikethrough' tag to work but it's not working. I've the following definition -

'HTML.Allowed' => 'h1,h2,h3,h4,h5,h6,s' // Note the last element, 's'

But this doesn't seem to work, as I get 'Element 's' not supported error. I then tried to add the element using following -

$def->addElement('s', 'Inline', 'Inline', 'Common', []);

With that line added, I do not get the error anymore, but I found out that the 's' tag gets automatically converted into '' tag. That is, the text -

WORD gets converted into

WORD

Can someone help me figure out what's going on and how to get strikethrough working?

Would really appreciate your help and support.

Re: Allowing strikethrough tags 's' not working
May 13, 2018 12:04AM

Can you post some code?

Author:
Your Email:

Subject:

HTML input is enabled. Make sure you escape all HTML and angled brackets with < and >.

Auto-paragraphing is enabled. Double newlines will be converted to paragraphs; for single newlines, use the pre tag.

Allowed tags: a, abbr, acronym, b, blockquote, caption, cite, code, dd, del, dfn, div, dl, dt, em, i, ins, kbd, li, ol, p, pre, s, strike, strong, sub, sup, table, tbody, td, tfoot, th, thead, tr, tt, u, ul, var.

For inputting literal code such as HTML and PHP for display, use CDATA tags to auto-escape your angled brackets, and pre to preserve newlines:

<pre><![CDATA[
Place code here
]]></pre>

Power users, you can hide this notice with:

.htmlpurifier-help {display:none;}

Message: